MEMBERS ONLINE: 0
REGISTERED MEMBERS: 18473
REGISTERED MOVIETEAMS: 685
NEWEST MEMBER: FeloN
NEWSITEMS: 618
LATEST COMPO-WINNER: bKr[ME]

Auto-login: - Forgot your password?

FORUM

Haco

, Germany
Joined: 18. Dec 2008
Posts: 84

chroma key & motion blur :(

#1 - 22. Nov 2021 13:41
Hi all,

Yes, I'm late to the party and it could be a stupid question, but:

I have a HLAE green matte stream. Captured at 80 fps (no hlae sampling/sps).
I use it in Vegas Pro and put the green matte/entity layer over my world stream and key the green out with the vanilla chroma key plugin.

Because I capture everything in higher fps (in this case 80 fps, for the green entity & world stream) to archive motion blur after the final vegas render (30 fps), the motion blur messes with my chroma keyed entity stream. Some green is visible in fast motion scenes (jumping players, weapon switches etc).

Currently I use 3 secondary color corrections to get rid of the green spill. It's ok, but not perfect.

I know I could also disable the resampling for the green entity clips, but I want to have motion blur. So that is not an option. Also, in this special case, I need the green entity stream. Normally I don't split the streams.

Is there a simpler solution that I just can't find? How did you archive motion blur on green entity streams in your movie?

Thanks a bunch
Dec
HLAE

Karlstad, Sweden
Joined: 7. Oct 2006
Posts: 2755
#2 - 22. Nov 2021 20:39
80 fps? That's a strange combination for a 30 fps output. :thinking:

One method would be to edit the scene / clip in enough slowmotion so there is no blur present, render it out, and then re-import it and increase its speed so you get back the resampling.

Another method would be to create a new Vegas project that is in 80 fps instead and edit the clip, render it, and import to your regular 30 fps project.

Last changed: 22. November 2021 20:41
Haco

, Germany
Joined: 18. Dec 2008
Posts: 84
#3 - 23. Nov 2021 16:27
Yeah =D Actually I am rendering at 60 fps (and source 90), so there is not too much motion blur.

The pre-render is a good idea, I'll try that. But I think I do it in AE, because it has the better output codecs for videos with alpha channel (and also the better chroma keyer =D)

Currently I use RealSmartMotionBlur on the entity layer to replicate the vegas resampling (vegas resampling for these clips is ofc disabled). Long render times but that's my alternative :D

Thanks
Dec
HLAE

Karlstad, Sweden
Joined: 7. Oct 2006
Posts: 2755
#4 - 24. Nov 2021 18:15
Haco wrote:
Actually I am rendering at 60 fps (and source 90)

You need to log in to write a post.