MEMBERS ONLINE: 0
REGISTERED MEMBERS: 18454
REGISTERED MOVIETEAMS: 684
NEWEST MEMBER: dozi
NEWSITEMS: 620
LATEST COMPO-WINNER: bKr[ME]

Auto-login: - Forgot your password?

FORUM

Mark7805
Mav Productions

, Canada
Joined: 8. Oct 2006
Posts: 179

x264 error

#1 - 7. Sep 2009 07:38
I get this error when I'm trying to encode to mp4.



[quote]======Encoding AAC audio======
Freeware Advanced Audio Coder
FAAC 1.24.1 (May 17 2005) UNSTABLE

Average bitrate: 128 kbps
Quantization quality: 100
Bandwidth: 16000 Hz
Object type: Low Complexity(MPEG-4) + M/S
Container format: MPEG-4 File Format (MP4)
Encoding L:\makemp4\Team-movie.wav to L:\makemp4\temp\Team-movie.m4a
frame | bitrate | elapsed/estim | play/CPU | ETA
3033/3033 (100%)| 128.0 | 5.0/5.0 | 14.00x | 0.0

==============================

======= x264 pass 1/3 ========
avis [info]: 1280x712 @ 30.00 fps (2112 frames)
x264 [error]: width % 16 != 0 or height % 16 != 0 (1280x712)
x264_encoder_open failed
==============================

======= x264 pass 2/3 ========
avis [info]: 1280x712 @ 30.00 fps (2112 frames)
x264 [error]: width % 16 != 0 or height % 16 != 0 (1280x712)
x264_encoder_open failed
==============================

======= x264 pass 3/3 ========
avis [info]: 1280x712 @ 30.00 fps (2112 frames)
x264 [error]: width % 16 != 0 or height % 16 != 0 (1280x712)
x264_encoder_open failed
==============================

=== Muxing Audio and Video ===
Cannot find H264 start code
Error: BitStream Not CompliantError importing L:\makemp4\temp\Team-movie.264#vi
deo: BitStream Not Compliant
==============================

If you have any errors, you haven't edited makemp4.bat correctly!!!
Otherwise the video is now done and can be found with the filename:
Team-movie.mp4

Press any key to continue . . .





Anyone know what the probably could be? What is contained in my makemp4.bat file is below




[quote]@echo off
:-------------------
: See http://wiki.meaz.org/index.php?title=Codecs:x264 for latest info
:-------------------

:START
:-------------------
: Start Configuration
:-------------------
: You need to export your movie as an avi with a filename.
: You need to export your movie sound as a wav with the same filename.
: Set the filename you will use on here.

set mymovie=Team-movie

:-------------------
:set the path to your files here (no \ at the end)
:-------------------

set mypath=L:\makemp4

:-------------------
:set the audio bitrate to use here
:-------------------

set myabitrate=128

:-------------------
:set the video bitrate to use here
:-------------------

set myvbitrate=5200

:-------------------
:set the video frame rate you used here
:-------------------

set myfps=30

:-------------------
:End Configuration
:-------------------


mkdir %mypath%\temp
cls

echo AVISource("%mypath%\%mymovie%.avi") > "%mypath%\%mymovie%.avs"
echo Crop(0,4,-0,-4) >> "%mypath%\%mymovie%.avs"
echo ConvertToYV12() >> "%mypath%\%mymovie%.avs"

echo ======Encoding AAC audio======
"bin\faac.exe" -b %myabitrate% -o "%mypath%\temp\%mymovie%.m4a" "%mypath%\%mymovie%.wav"
echo ==============================
echo.

echo ======= x264 pass 1/3 ========
"bin\x264.exe" -p 1 --bitrate %myvbitrate% --ref 3 --bframes 3 --subme 6 --weightb --analyse all --8x8dct --qpmin 4 --qpstep 6 --merange 24 --me umh --progress --no-psnr --stats "temp\x264.stats" --output NUL "%mymovie%.avs"
echo ==============================
echo.

echo ======= x264 pass 2/3 ========
"bin\x264.exe" -p 3 --bitrate %myvbitrate% --ref 3 --bframes 3 --subme 6 --weightb --analyse all --8x8dct --qpmin 4 --qpstep 6 --merange 24 --me umh --progress --no-psnr --stats "temp\x264.stats" --output NUL "%mymovie%.avs"
echo ==============================
echo.

echo ======= x264 pass 3/3 ========
"bin\x264.exe" -p 2 --bitrate %myvbitrate% --ref 3 --bframes 3 --subme 6 --weightb --analyse all --8x8dct --qpmin 4 --qpstep 6 --merange 24 --me umh --progress --no-psnr --stats "temp\x264.stats" --output "temp\%mymovie%.264" "%mymovie%.avs"
echo ==============================
echo.

echo === Muxing Audio and Video ===
"bin\mp4box" -new -add "%mypath%\temp\%mymovie%.264#video" -add "%mypath%\temp\%mymovie%.m4a#audio" -fps %myfps% "%mypath%\%mymovie%.mp4"
echo ==============================
echo.

if EXIST "%mypath%\%mymovie%.mp4" rmdir /S /Q temp
del "%mypath%\%mymovie%.avs"

:END
echo If you have any errors, you haven't edited makemp4.bat correctly!!!
echo Otherwise the video is now done and can be found with the filename:
echo %mymovie%.mp4
echo.
pause
Last changed: 7. September 2009 07:38
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2766
#2 - 7. Sep 2009 08:16
1 use nero aac, better than faac

2 use legion :)

3 what x264 ? noone can help you without the version
kendo
volodja pictures

Hamilton, Scotland, Latvia
Joined: 28. Mar 2008
Posts: 1233
#3 - 7. Sep 2009 08:21
do as juGGa says and you will solve your problem, he is expert in such things!
You need to log in to write a post.