MEMBERS ONLINE: 0
REGISTERED MEMBERS: 18432
REGISTERED MOVIETEAMS: 684
NEWEST MEMBER: root666
NEWSITEMS: 572
LATEST COMPO-WINNER: bKr[ME]

Auto-login: - Forgot your password?

FORUM

Other help > Legion 1.5.0
Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 >>
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760

Legion 1.5.0

#1 - 26. Aug 2009 13:18
1500 Downloads before launching 1.5.0, about 50 over 1 minute movies ( that i have seen ), the result of a year of work :

You can find a full tut in the style guides under the name "moviemaking for beginners"

Short tutorial :

Download Legion 1.5.0 .bat OR Legion 1.5.0 .exe

Extract using 7zip, install :
avisynth 2.5.8
Haali splitter
ffdshow tryouts latest build ( highest rev XXXX )
if you do not have them installed.

Render uncompressed .avi video and .wav sound from vegas, name them movie.avi / movie.wav, if you have 2 audio tracks name the second audio track movie2.wav

For bat have the legion.bat and bin folder in the same folder, very close to the root, the folder name must have no spaces! ( ex : "partition:/encoding" is k, "partition:/encoding stuff" is not k )

Enjoy.



Last changed: 1. March 2010 19:39
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#2 - 26. Aug 2009 13:32
DESTRUKTOR on the other thread wrote:
jugga, why don't u add an option for compressing video only? because if .wav file is missing u can't compress anything.. for example when only movie.avi is found in the directory, it says "A sound file was not found. Do you want to compress without sound?" or something like that :D


I will remove the audio check and leave only the video check and you can copy the .264 file from "/movie_2d/t1" folder for x264

and mux on your own

but i do not know why, nero aac at q 0.5 is better than any mp3

noted, will fix

LE : fixed

murder she wrote:
"%mypath%\bin\choice.exe" /C:YN /N /t:y,10 "No sound file found. Press Y to compress without sound, Press N to exit."
IF errorlevel 2 goto X2
IF errorlevel 1 goto X1
:X1
set outxvid="%mypath%\%mpath%\%mymovie%_xvid_no_sound.avi"
set outdivx="%mypath%\%mpath%\%mymovie%_divx_no_sound.264"
set outx264="%mypath%\%mpath%\%mymovie%_x264_no_sound.264"
GOTO ENCODING
:X2
GOTO OVERERROR2


if no audio output is made with _no_audio prefix

Last changed: 26. August 2009 13:44
h y t e x
Authentic-Pictures

Aarhus, Denmark
Joined: 7. Oct 2006
Posts: 2584
#3 - 26. Aug 2009 13:51
Where does he say anything about muxing on your own?
I guess he just wondered, if you want a video without audio at all.
destruktor
Authentic-Pictures

Capital City, Macedonia
Joined: 10. Jun 2008
Posts: 1691
#4 - 26. Aug 2009 13:53
HYTEX wrote:
Where does he say anything about muxing on your own?
I guess he just wondered, if you want a video without audio at all.


ye i was talking about a video without audio

EDIT: it still asks for movie.wav file :/

Last changed: 26. August 2009 13:57
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#5 - 26. Aug 2009 14:08
fixed locally

i have to upload 1.4.1 lol

also added a "encode only audio" if no video is there :P

so no audio it encodes only video and does not try to mux

no video encodes only audio

no nothing error

both there normal encode

script :

murder she wrote:
if EXIST "%mypath%\%mymovie%.avi" GOTO check
goto NOFILES1
:check
if EXIST "%mypath%\%mymovie%.wav" GOTO check2
goto NOFILES2
:check2
set skip1=@REM
set skip1=@REM
set skip3=@REM
set skip4=@REM
set outxvid="%mypath%\%mpath%\T2\%mymovie%.avi"
set outdivx="%mypath%\%mpath%\T3\%mymovie%.264"
set outx264="%mypath%\%mpath%\T1\%mymovie%.264"
set outsound="%mypath%\%mpath%\T1\%mymovie%.m4a"
set outsound2="%mypath%\%mpath%\T1\%mymovie%2.m4a"
GOTO ENCODING
:NOFILES1
echo.
echo You do not have movie.avi in the same folder as the bat!
echo.
if EXIST "%mypath%\%mymovie%.wav" GOTO GGG
GOTO OVERERROR2
:GGG
cls
"%mypath%\bin\choice.exe" /C:YN /N /t:y,10 "No video file found. Press Y to compress just sound, Press N to exit."
IF errorlevel 2 goto X2
IF errorlevel 1 goto X1
:X1
set VIDEOS=GOTO over
set outsound="%mypath%\%mpath%\%mymovie%_no_sound_1st_track.m4a"
set outsound2="%mypath%\%mpath%\%mymovie%_no_sound_2nd_track.m4a"
goto AUDIOENC
:X2
GOTO OVERERROR2
:NOFILES2
echo.
cls
"%mypath%\bin\choice.exe" /C:YN /N /t:y,10 "No sound file found. Press Y to compress without sound, Press N to exit."
IF errorlevel 2 goto X2
IF errorlevel 1 goto X1
:X1
set skip1=goto encode_xvid
set skip1=goto encode_divx
set skip3=goto encode_x264
set skip4=goto over
set outxvid="%mypath%\%mpath%\%mymovie%_xvid_no_sound.avi"
set outdivx="%mypath%\%mpath%\%mymovie%_divx_no_sound.264"
set outx264="%mypath%\%mpath%\%mymovie%_x264_no_sound.264"
GOTO ENCODING
:X2
GOTO OVERERROR2


thnx for the feature request!

Last changed: 26. August 2009 14:10
destruktor
Authentic-Pictures

Capital City, Macedonia
Joined: 10. Jun 2008
Posts: 1691
#6 - 26. Aug 2009 15:20
when are you uploading 1.4.1 ? :)
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#7 - 26. Aug 2009 15:21
20 minutes, needs testing.

Download Legion 1.4.1

Last changed: 26. August 2009 15:50
destruktor
Authentic-Pictures

Capital City, Macedonia
Joined: 10. Jun 2008
Posts: 1691
#8 - 26. Aug 2009 20:26
woah! 1.4.1 is awesome! i got 7,5 mb for a 22 second clip with very very good quality! xvid autobitrate. thank you man!

Last changed: 26. August 2009 20:27
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#9 - 26. Aug 2009 20:45
upload and pm me

well xvid has ~2x bitrate than x264 so try to encode all

xvid and divx settings are final ( i have to repack divx every 4/6 months cuz it expires .. beta )

x264 will change with weightp ( much better fades and fx that use fades ) soon

anyway if no more problems i will make this 1.4.1 final now that i've added suport for encode audio only

so its great for encoding audio only too, better than any mp3

please post if any x264 errors
destruktor
Authentic-Pictures

Capital City, Macedonia
Joined: 10. Jun 2008
Posts: 1691
#10 - 27. Aug 2009 03:22
juGGaKNot wrote:
upload and pm me

well xvid has ~2x bitrate than x264 so try to encode all

xvid and divx settings are final ( i have to repack divx every 4/6 months cuz it expires .. beta )

x264 will change with weightp ( much better fades and fx that use fades ) soon

anyway if no more problems i will make this 1.4.1 final now that i've added suport for encode audio only

so its great for encoding audio only too, better than any mp3

please post if any x264 errors


http://www.megaupload.com/?d=5IJRD707

didn't test x264 yet, probably never will cuz it has very slow encoding time.. xvid for life :)
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#11 - 27. Aug 2009 10:34
Bit rate mode : Variable
Bit rate : 2 567 Kbps
Maximum bit rate : 8 014 Kbps

its too short, the encoder does not get to the autobitrate, for 1024 25fps is 7000 + 300 more for 30 fps so 7300

yours was short and only 2500 :P


btw

Frame rate mode : Variable
Frame rate : 29.956 fps
Minimum frame rate : 15.000 fps
Maximum frame rate : 30.000 fps
Original frame rate : 30.000 fps

thats weird, you use variable fps ?

autobitrate is set for maximum quality not size, keep that in mind.

Last changed: 27. August 2009 10:35
destruktor
Authentic-Pictures

Capital City, Macedonia
Joined: 10. Jun 2008
Posts: 1691
#12 - 27. Aug 2009 11:04
juGGaKNot wrote:
Bit rate mode : Variable
Bit rate : 2 567 Kbps
Maximum bit rate : 8 014 Kbps

its too short, the encoder does not get to the autobitrate, for 1024 25fps is 7000 + 300 more for 30 fps so 7300

yours was short and only 2500 :P


btw

Frame rate mode : Variable
Frame rate : 29.956 fps
Minimum frame rate : 15.000 fps
Maximum frame rate : 30.000 fps
Original frame rate : 30.000 fps

thats weird, you use variable fps ?

autobitrate is set for maximum quality not size, keep that in mind.


so only 2500 kbps was used on this clip? btw i use 30 fps on vegas, 120 fps on hlae..
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#13 - 27. Aug 2009 11:37
Bit rate : 2 567 Kbps
Maximum bit rate : 8 014 Kbps

yes

too short, xvid does not worm up fast.
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#14 - 27. Aug 2009 20:52
Updated to 1.4.2

much better audio/video script :

if only movie.wav than you can choose encode audio or exit
if only movie.avi than you can choose encode video or exit

if both you can

encode audio only
encode video only
encode both and mux

also made smaller autobitrate for xvid and divx since they do not have "visual optimisations" like x264 that can suck on some sources

also updated mp4box and nircmd.

also added fast first pass for x264 to make it faster

Last changed: 27. August 2009 21:56
Dec
HLAE

Karlstad, Sweden
Joined: 7. Oct 2006
Posts: 2619
#15 - 6. Sep 2009 11:22
You'll update next month, kind of? (The final version?)
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#16 - 6. Sep 2009 12:42
yes but the x264 devs are not commiting weightp

their doing slices and threading ( this is like multicore bframes ) to make it faster than the weightp thing to help fades

bframes are like a hdd, one of the slow parts in x264
teemong

-, Netherlands
Joined: 8. Oct 2006
Posts: 389
#17 - 7. Sep 2009 22:38
Oke so I made something in Vegas and rendered 2 files (video/audio) uncompressed and called them both movie.
I Installed legion in C:/
I placed both files into C:/
I started the .bat file and it worked. I got 2 files in /T1/ named: movie2.avs & movie3.avs

What to do now?
Barahuna

, Germany
Joined: 3. Jul 2007
Posts: 171
#18 - 8. Sep 2009 00:45
ive done it wit xvid but still got no sound :/ will try this night the other codecs and give you feedback..
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2760
#19 - 8. Sep 2009 08:13
it did not work teemons, lol

bara ?

post the log, lol

anyway uploading 1.4.5 today, there were some bugs in the script

redone all of it lol
Barahuna

, Germany
Joined: 3. Jul 2007
Posts: 171
#20 - 8. Sep 2009 17:46
where is the log file? sry too tired to search it wether on this topic neither on folder sry11

Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 >>

You need to log in to write a post.