MEMBERS ONLINE: 0
REGISTERED MEMBERS: 18453
REGISTERED MOVIETEAMS: 684
NEWEST MEMBER: johnybravosm
NEWSITEMS: 619
LATEST COMPO-WINNER: bKr[ME]

Auto-login: - Forgot your password?

FORUM

piu

, Brazil
Joined: 9. Mar 2009
Posts: 84

Problem with x264

#1 - 2. May 2009 03:30
Hello everyone. I downloaded the x264 guide by daniel and configured everything. But I got this error when i put the .mp3 file:

Generating jobs. No desired size.
User doesn't care what the filesize is. Leaving bitrate/qp/crf at the profile's valueLooking for job processor for job...
Processor found!


------------------------------------------------------

Starting job job1-1 at 10:29:25 PM
Starting preprocessing of job...
Preprocessing finished!
encoder commandline:

successfully started encoding
Processing ended at 10:29:25 PM
----------------------

Log for job job1-1

Error:
MeGUI.AviSynthException: Script error: there is no function named "NicMPG123Source"
at MeGUI.AviSynthClip..ctor(String func, String arg, AviSynthColorspace forceColorspace, AviSynthScriptEnvironment env)
at MeGUI.AviSynthAudioEncoder.encode()
----------------------
The current job contains errors. Skipping chained jobs
End of log for job1-1
-------------------------------------------------------

And its just with the mp3 file, a movie without sound there's no error... pls help.
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2766
#2 - 2. May 2009 07:43
piucs wrote:
Hello everyone. I downloaded the x264 guide by daniel and configured everything. But I got this error when i put the .mp3 file:

Generating jobs. No desired size.
User doesn't care what the filesize is. Leaving bitrate/qp/crf at the profile's valueLooking for job processor for job...
Processor found!


------------------------------------------------------

Starting job job1-1 at 10:29:25 PM
Starting preprocessing of job...
Preprocessing finished!
encoder commandline:

successfully started encoding
Processing ended at 10:29:25 PM
----------------------

Log for job job1-1

Error:
MeGUI.AviSynthException: Script error: there is no function named "NicMPG123Source"
at MeGUI.AviSynthClip..ctor(String func, String arg, AviSynthColorspace forceColorspace, AviSynthScriptEnvironment env)
at MeGUI.AviSynthAudioEncoder.encode()
----------------------
The current job contains errors. Skipping chained jobs
End of log for job1-1
-------------------------------------------------------

And its just with the mp3 file, a movie without sound there's no error... pls help.


render without sound, mux with mkvtoolnix.
piu

, Brazil
Joined: 9. Mar 2009
Posts: 84
#3 - 2. May 2009 13:30
I've no idea how to make it, juGGaKNot, can you tell me?
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2766
#4 - 2. May 2009 16:54
piucs wrote:
I've no idea how to make it, juGGaKNot, can you tell me?


render without sound, x264 ( raw ), then open mkvtoolnix and mux them.
piu

, Brazil
Joined: 9. Mar 2009
Posts: 84
#5 - 3. May 2009 21:36
Before doing what you said, juGGaKNoT, i tried something and it worked. I've just changed the sound format, .mp3 to .wav and it's now perfect. Thank you anyway! :D
zarz

, Czech Republic
Joined: 27. Apr 2009
Posts: 13
#6 - 9. May 2009 11:17
If I understand the problem right... then your sound isnt muxing with your video. Update it. When you open mEGUI itll say updates are available... Do you wih to update: Click yes. I had the same problem then i updates and it was fine.
atwspoon

Wichita, Kansas, United States of America
Joined: 11. Nov 2007
Posts: 1166
#7 - 9. May 2009 15:41
I ewww @ meGUI and their bad updates
long live .bat beta!

Last changed: 9. May 2009 15:43
destruktor
Authentic-Pictures

Capital City, Macedonia
Joined: 10. Jun 2008
Posts: 1696
#8 - 21. Jun 2009 13:39
ripbot is also kewl
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2766
#9 - 21. Jun 2009 14:29
DESTRUKTOR wrote:
ripbot is also kewl


But it can fail if you have ace or k-lite codecs crap pack.
juggaknot
Airwalk Media

LOLville, Romania
Joined: 2. Oct 2007
Posts: 2766
#10 - 21. Jun 2009 14:29
bad post.

Last changed: 21. June 2009 14:30
Megastock

, Sweden
Joined: 19. Jun 2009
Posts: 6
#11 - 23. Jun 2009 08:55
Don't import as MP3 import as WAV. So render the music in .wav much better than mp3
You need to log in to write a post.